Je reçois une erreur lors de l’installation de Cordova

Lorsque je souhaite installer Cordova avec NPM, le message d’erreur suivant s’affiche:

Error: No compatible version found: ripple-emulator@'>=0.9.15' 

Node, Nodejs et NPM sont tous installés. Je n’ai rien trouvé qui puisse aider.
Ma commande était:

 npm install cordova 

OU

 sudo npm install -g cordova 

Votre version de Node.js est probablement trop ancienne. ripple-emulator requirejs au moins 0.8.0, vérifiez votre version à l’aide de node -v .

Si tel est le cas, vous devez soit obtenir un nouveau paquet de votre dissortingbution, soit télécharger et installer une version plus récente de nodejs.org .

C’est ce qui a fonctionné pour moi (bien que j’aie installé avec apt-get, j’avais le noeud 0.6 alors que la version la plus récente était la 0.10.31): Ajoutez un noeud à vos sources:

 sudo apt-add-rep ository ppa:chris-lea/node.js 

puis mettre à jour les sources

 sudo apt-get update 

puis installez (ou mettez à jour) nodejs

 sudo apt-get install nodejs 

source: http://doc.ubuntu-fr.org/nodejs