erreur de lancement d’installation par npm dans node-sass

node-sass@2.1.1 install /home/user/Documents/project/node_modules/node-sass > node scripts/install.js WARN invalid config loglevel="notice" Can not download file from https://raw.githubusercontent.com/sass/node-sass-binaries/v2.1.1/linux-x64-node-8.2/binding.node > node-sass@2.1.1 postinstall /home/user/Documents/project/node_modules/node-sass > node scripts/build.js module.js:487 throw err; ^ Error: Cannot find module '/home/user/Documents/project/node_modules/node-sass/node_modules/pangyp/bin/node-gyp' at Function.Module._resolveFilename (module.js:485:15) at Function.Module._load (module.js:437:25) at Function.Module.runMain (module.js:605:10) at startup (bootstrap_node.js:158:16) at bootstrap_node.js:575:3 Build failed added 2186 packages in 42.166s 

J’ai essayé jusqu’à présent:

  • npm reconstruire
  • npm reconstruire node-sass
  • npm désinstaller -g node-sass
  • rm -rf node_module
  • La version minimale prise en charge par le nœud 8 est la version 4.5.3 . De prime abord, je ne pense pas que 2.x supportera quoi que ce soit au-dessus du noeud 0.12, qui est EOL

    Vous devez faire les prochaines étapes et cela devrait fonctionner:

     rm -rf node_modules package-lock.json npm install --saveDev node-sass@4.5.3 npm install 

    Voila 🙂