Ember-cli – Bower ne s’installe pas correctement

J’ai essayé de cloner et de lancer un projet ember-cli sur lequel mon équipe travaillait. Je fais installer npm puis Bower installer puis ember serveur. Cela vient:

Path or pattern "bower_components/moment/moment.js" did not match any files [ssortingng exception] 

Le dossier qui était supposé être moment a été nommé momentjs à la place. Bizarre. Je l’ai renommé et j’ai encore essayé:

 Path or pattern "bower_components/ember-simple-auth/simple-auth.amd.js" did not match any files [ssortingng exception] 

Ember-simple-auth n’est même pas supposé faire partie de ce projet, mon coéquipier m’a informé qu’il l’avait supprimé. Que se passe-t-il?

Mon bower.json:

 { "name": "brkb-web", "dependencies": { "handlebars": "~1.3.0", "jquery": "^1.11.1", "ember": "1.7.0", "ember-data": "1.0.0-beta.10", "ember-resolver": "~0.1.7", "loader": "stefanpenner/loader.js#1.0.1", "ember-cli-shims": "stefanpenner/ember-cli-shims#0.0.3", "ember-cli-test-loader": "rwjblue/ember-cli-test-loader#0.0.4", "ember-load-initializers": "stefanpenner/ember-load-initializers#0.0.2", "ember-qunit": "0.1.8", "ember-qunit-notifications": "0.0.4", "qunit": "~1.15.0", "font-awesome": "~4.2.0", "pikaday": "~1.2.0", "momentjs": "~2.8.3", "fancybox": "~2.1.5", "ember-validations": "http://builds.dockyard.com.s3.amazonaws.com/ember-validations/ember-validations-latest.js" }, "devDependencies": { "bootstrap": "~3.2.0" } } 

Mon package.json:

 { "name": "brkb-web", "version": "0.0.0", "private": true, "directories": { "doc": "doc", "test": "tests" }, "scripts": { "start": "ember server", "build": "ember build", "test": "ember test" }, "repository": "https://github.com/stefanpenner/ember-cli", "engines": { "node": ">= 0.10.0" }, "author": "", "license": "MIT", "devDependencies": { "body-parser": "^1.2.0", "broccoli-asset-rev": "0.1.1", "broccoli-ember-hbs-template-comstackr": "^1.6.1", "ember-cli": "0.0.46", "ember-cli-datepicker": "^1.2.1", "ember-cli-ic-ajax": "0.1.1", "ember-cli-inject-live-reload": "^1.0.2", "ember-cli-qunit": "0.1.0", "ember-cli-simple-auth": "^0.6.7", "ember-data": "1.0.0-beta.10", "express": "^4.8.5", "glob": "^4.0.5" } } 

S’il y a autre chose que vous devez savoir, je peux éditer ce post avec.

Vous utilisez toujours le paquet ember-cli-simple-auth qui importera le paquet Ember Simple Auth bower. Si vous souhaitez supprimer Ember Simple Auth du projet, vous devez également le supprimer.